logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libsoup-2.99.7.ebuild (2944B)


  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. VALA_USE_DEPEND="vapigen"
  5. inherit gnome.org meson-multilib vala xdg
  6. DESCRIPTION="HTTP client/server library for GNOME"
  7. HOMEPAGE="https://wiki.gnome.org/Projects/libsoup"
  8. LICENSE="LGPL-2.1+"
  9. SLOT="3/3.0"
  10. # TODO: Default enable brotli at some point? But in 2.70.0 not advertised to servers yet - https://gitlab.gnome.org/GNOME/libsoup/issues/146
  11. IUSE="brotli gssapi gtk-doc +introspection samba ssl sysprof test +vala"
  12. RESTRICT="!test? ( test )"
  13. REQUIRED_USE="vala? ( introspection )"
  14. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
  15. DEPEND="
  16. >=dev-libs/glib-2.67:2[${MULTILIB_USEDEP}]
  17. >=dev-db/sqlite-3.8.2:3[${MULTILIB_USEDEP}]
  18. >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
  19. brotli? ( >=app-arch/brotli-1.0.6-r1:=[${MULTILIB_USEDEP}] )
  20. >=net-libs/libpsl-0.20[${MULTILIB_USEDEP}]
  21. sysprof? ( >=dev-util/sysprof-capture-3.40.1:4[${MULTILIB_USEDEP}] )
  22. sys-libs/zlib
  23. gssapi? ( virtual/krb5[${MULTILIB_USEDEP}] )
  24. introspection? ( >=dev-libs/gobject-introspection-1.54:= )
  25. samba? ( net-fs/samba )
  26. "
  27. RDEPEND="${DEPEND}
  28. >=net-libs/glib-networking-2.38.2[ssl?,${MULTILIB_USEDEP}]
  29. "
  30. BDEPEND="
  31. dev-libs/glib
  32. dev-util/glib-utils
  33. gtk-doc? ( >=dev-util/gtk-doc-1.20
  34. app-text/docbook-xml-dtd:4.1.2 )
  35. >=sys-devel/gettext-0.19.8
  36. virtual/pkgconfig
  37. vala? ( $(vala_depend) )
  38. "
  39. # test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
  40. # apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
  41. # apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
  42. # dev-lang/php[apache2,xmlrpc]
  43. # net-misc/curl
  44. # net-libs/glib-networking[ssl])"
  45. PATCHES=(
  46. # Disable apache tests until they are usable on Gentoo, bug #326957
  47. "${FILESDIR}"/disable-apache-tests.patch
  48. )
  49. src_prepare() {
  50. use vala && vala_src_prepare
  51. xdg_src_prepare
  52. # https://gitlab.gnome.org/GNOME/libsoup/issues/159 - could work with libnss-myhostname
  53. sed -e '/hsts/d' -i tests/meson.build || die
  54. }
  55. src_configure() {
  56. # FIXME: we need addpredict to workaround bug #324779 until
  57. # root cause (bug #249496) is solved
  58. # But necessary while apache tests are disabled
  59. #addpredict /usr/share/snmp/mibs/.index
  60. multilib-minimal_src_configure
  61. }
  62. multilib_src_configure() {
  63. local emesonargs=(
  64. $(meson_feature gssapi)
  65. -Dkrb5_config="${CHOST}-krb5-config"
  66. $(meson_feature samba ntlm)
  67. $(meson_feature brotli)
  68. -Dntlm_auth="${EPREFIX}/usr/bin/ntlm_auth"
  69. -Dtls_check=false # disables check, we still rdep on glib-networking
  70. -Dgnome=false
  71. $(meson_native_use_feature introspection)
  72. $(meson_native_use_feature vala vapi)
  73. $(meson_native_use_bool gtk-doc gtk_doc)
  74. $(meson_use test tests)
  75. -Dinstalled_tests=false
  76. $(meson_feature sysprof)
  77. )
  78. meson_src_configure
  79. }