logo

overlay

My own overlay for experimentations, use with caution, no support is provided

libqmatrixclient-0.5.3.ebuild (737B)


      1 # Copyright 2018-2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit cmake-utils
      7 
      8 DESCRIPTION="A Qt5 library to write cross-platfrom clients for Matrix"
      9 HOMEPAGE="https://github.com/QMatrixClient/libqmatrixclient https://matrix.org/docs/projects/sdk/libqmatrixclient.html"
     10 SRC_URI="https://github.com/QMatrixClient/libqmatrixclient/archive/${PV}.tar.gz -> ${P}.tar.gz"
     11 SLOT="0"
     12 LICENSE="LGPL-2.1"
     13 KEYWORDS="~amd64"
     14 
     15 DEPEND="
     16 	dev-qt/qtnetwork:5=
     17 	dev-qt/qtgui:5=
     18 	dev-qt/qtmultimedia:5=
     19 "
     20 
     21 S="${WORKDIR}/libQuotient-${PV}"
     22 
     23 src_configure() {
     24 	local mycmakeargs=(
     25 		-DCMAKE_INSTALL_INCLUDEDIR=include/libqmatrixclient
     26 	)
     27 
     28 	cmake-utils_src_configure
     29 }