logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libnice-0.1.18-r1.ebuild (1597B)


  1. # Copyright 1999-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit meson-multilib xdg
  5. DESCRIPTION="An implementation of the Interactice Connectivity Establishment standard (ICE)"
  6. HOMEPAGE="https://nice.freedesktop.org/wiki/"
  7. SRC_URI="https://nice.freedesktop.org/releases/${P}.tar.gz"
  8. LICENSE="|| ( MPL-1.1 LGPL-2.1 )"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
  11. IUSE="+gnutls gstreamer +introspection +upnp"
  12. RDEPEND="
  13. >=dev-libs/glib-2.54:2[${MULTILIB_USEDEP}]
  14. introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
  15. gnutls? ( >=net-libs/gnutls-2.12.0:0=[${MULTILIB_USEDEP}] )
  16. !gnutls? (
  17. dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
  18. upnp? ( >=net-libs/gupnp-igd-0.2.4:=[${MULTILIB_USEDEP}] )
  19. gstreamer? (
  20. media-libs/gstreamer:1.0[${MULTILIB_USEDEP}]
  21. media-libs/gst-plugins-base:1.0[${MULTILIB_USEDEP}]
  22. !<media-plugins/gst-plugins-libnice-0.1.18-r1
  23. )
  24. "
  25. DEPEND="${RDEPEND}"
  26. BDEPEND="
  27. dev-util/glib-utils
  28. virtual/pkgconfig
  29. "
  30. src_prepare() {
  31. default
  32. # https://bugs.gentoo.org/847844 https://bugs.gentoo.org/678142
  33. sed -i '/test-set-port-range/d' tests/meson.build || die
  34. }
  35. multilib_src_configure() {
  36. local emesonargs=(
  37. -Dcrypto-library=$(usex gnutls gnutls openssl)
  38. $(meson_native_use_feature introspection)
  39. $(meson_feature upnp gupnp)
  40. $(meson_feature gstreamer)
  41. )
  42. meson_src_configure
  43. #if multilib_is_native_abi; then
  44. # ln -s {"${S}"/,}docs/reference/libnice/html || die
  45. #fi
  46. }
  47. multilib_src_install_all() {
  48. einstalldocs
  49. }