logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

glib-networking-2.72.0.ebuild (1969B)


  1. # Copyright 1999-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit gnome.org gnome2-utils meson-multilib xdg
  5. DESCRIPTION="Network-related giomodules for glib"
  6. HOMEPAGE="https://gitlab.gnome.org/GNOME/glib-networking"
  7. LICENSE="LGPL-2.1+"
  8. SLOT="0"
  9. IUSE="gnome +gnutls +libproxy openssl test +ssl"
  10. RESTRICT="!test? ( test )"
  11. KEYWORDS="~amd64"
  12. REQUIRED_USE="ssl? ( || ( gnutls openssl ) )"
  13. RDEPEND="
  14. >=dev-libs/glib-2.69.0:2[${MULTILIB_USEDEP}]
  15. libproxy? ( >=net-libs/libproxy-0.4.11-r1:=[${MULTILIB_USEDEP}] )
  16. gnutls? ( >=net-libs/gnutls-3.7.2:=[${MULTILIB_USEDEP}] )
  17. ssl? ( app-misc/ca-certificates )
  18. openssl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
  19. gnome? ( gnome-base/gsettings-desktop-schemas )
  20. "
  21. DEPEND="${RDEPEND}
  22. test? ( net-libs/gnutls[pkcs11] )
  23. "
  24. BDEPEND="
  25. >=sys-devel/gettext-0.19.8
  26. virtual/pkgconfig
  27. test? ( sys-apps/dbus )
  28. "
  29. src_prepare() {
  30. default
  31. xdg_environment_reset
  32. if ! use test ; then
  33. # Don't build tests unconditionally
  34. # This is a hack to avoid needing gnutls[pkcs11] when USE=-test
  35. # It may become a real runtime dependency in future
  36. # Please check!
  37. # bug #777462
  38. sed -i "/^subdir('tests')/d" tls/meson.build || die
  39. fi
  40. }
  41. multilib_src_configure() {
  42. local emesonargs=(
  43. $(meson_feature gnutls)
  44. $(meson_feature openssl)
  45. $(meson_feature libproxy)
  46. $(meson_feature gnome gnome_proxy)
  47. -Dinstalled_tests=false
  48. -Dstatic_modules=false
  49. )
  50. meson_src_configure
  51. }
  52. multilib_src_test() {
  53. dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
  54. }
  55. pkg_postinst() {
  56. xdg_pkg_postinst
  57. multilib_pkg_postinst() {
  58. gnome2_giomodule_cache_update \
  59. || die "Update GIO modules cache failed (for ${ABI})"
  60. }
  61. multilib_foreach_abi multilib_pkg_postinst
  62. }
  63. pkg_postrm() {
  64. xdg_pkg_postrm
  65. multilib_pkg_postrm() {
  66. gnome2_giomodule_cache_update \
  67. || die "Update GIO modules cache failed (for ${ABI})"
  68. }
  69. multilib_foreach_abi multilib_pkg_postrm
  70. }