logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

glib-networking-2.66.0.ebuild (1310B)


  1. # Copyright 2018-2020 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit gnome2-utils meson xdg multilib-minimal
  5. DESCRIPTION="Network-related giomodules for glib"
  6. HOMEPAGE="https://gitlab.gnome.org/GNOME/${PN}"
  7. SRC_URI="https://ftp.gnome.org/pub/GNOME/sources/${PN}/$(ver_cut 1-2)/${P}.tar.xz"
  8. LICENSE="LGPL-2.1+"
  9. SLOT="0"
  10. IUSE="gnome gnutls +libproxy +openssl test ssl"
  11. KEYWORDS="~amd64"
  12. REQUIRED_USE="ssl? ( || ( gnutls openssl ) )"
  13. DEPEND="
  14. >=dev-libs/glib-2.63.0:2[${MULTILIB_USEDEP}]
  15. libproxy? ( >=net-libs/libproxy-0.3.1:=[${MULTILIB_USEDEP}] )
  16. gnutls? ( >=net-libs/gnutls-3.4.6:=[${MULTILIB_USEDEP}] )
  17. openssl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
  18. "
  19. multilib_src_configure() {
  20. local emesonargs=(
  21. $(meson_feature gnutls)
  22. $(meson_feature openssl)
  23. $(meson_feature libproxy)
  24. $(meson_feature gnome gnome_proxy)
  25. -Dinstalled_tests=false
  26. -Dstatic_modules=false
  27. )
  28. meson_src_configure
  29. }
  30. multilib_src_compile() {
  31. meson_src_compile
  32. }
  33. multilib_src_install() {
  34. meson_src_install
  35. }
  36. multilib_src_test() {
  37. meson_src_test
  38. }
  39. pkg_postinst() {
  40. xdg_pkg_postinst
  41. multilib_foreach_abi gnome2_giomodule_cache_update
  42. }
  43. pkg_postrm() {
  44. xdg_pkg_postrm
  45. multilib_foreach_abi gnome2_giomodule_cache_update
  46. }