logo

overlay

My own overlay for experimentations, use with caution, no support is provided

glib-networking-2.64.3.ebuild (1393B)


      1 # Copyright 2018-2020 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit gnome2-utils meson xdg multilib-minimal
      7 
      8 DESCRIPTION="Network-related giomodules for glib"
      9 HOMEPAGE="https://gitlab.gnome.org/GNOME/${PN}"
     10 SRC_URI="https://ftp.gnome.org/pub/GNOME/sources/${PN}/$(ver_cut 1-2)/${P}.tar.xz"
     11 
     12 LICENSE="LGPL-2.1+"
     13 SLOT="0"
     14 IUSE="gnome gnutls +libproxy libressl +openssl test ssl"
     15 KEYWORDS="~amd64"
     16 
     17 REQUIRED_USE="ssl? ( || ( gnutls openssl ) )"
     18 
     19 DEPEND="
     20 	>=dev-libs/glib-2.63.0:2[${MULTILIB_USEDEP}]
     21 	libproxy? ( >=net-libs/libproxy-0.3.1:=[${MULTILIB_USEDEP}] )
     22 	gnutls? ( >=net-libs/gnutls-3.4.6:=[${MULTILIB_USEDEP}] )
     23 	openssl? (
     24 		!libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
     25 		libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
     26 	)
     27 "
     28 
     29 multilib_src_configure() {
     30 	local emesonargs=(
     31 		$(meson_feature gnutls)
     32 		$(meson_feature openssl)
     33 		$(meson_feature libproxy)
     34 		$(meson_feature gnome gnome_proxy)
     35 		-Dinstalled_tests=false
     36 		-Dstatic_modules=false
     37 	)
     38 
     39 	meson_src_configure
     40 }
     41 
     42 multilib_src_compile() {
     43 	meson_src_compile
     44 }
     45 
     46 multilib_src_install() {
     47 	meson_src_install
     48 }
     49 
     50 multilib_src_test() {
     51 	meson_src_test
     52 }
     53 
     54 pkg_postinst() {
     55 	xdg_pkg_postinst
     56 	multilib_foreach_abi gnome2_giomodule_cache_update
     57 }
     58 
     59 pkg_postrm() {
     60 	xdg_pkg_postrm
     61 	multilib_foreach_abi gnome2_giomodule_cache_update
     62 }