logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

tootle-9999.ebuild (728B)


  1. # Copyright 1999-2018 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit meson vala gnome2-utils git-r3
  5. DESCRIPTION="GTK3 client for Mastodon API"
  6. HOMEPAGE="https://github.com/bleakgrey/tootle"
  7. SRC_URI=""
  8. EGIT_REPO_URI="https://github.com/bleakgrey/tootle"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS=""
  12. IUSE=""
  13. DEPEND="
  14. dev-libs/glib
  15. dev-libs/granite
  16. dev-libs/json-glib
  17. net-libs/libsoup:2.4
  18. x11-libs/gtk+:3
  19. "
  20. RDEPEND="${DEPEND}"
  21. src_prepare() {
  22. vala_src_prepare
  23. default
  24. }
  25. pkg_preinst() {
  26. gnome2_gconf_savelist
  27. gnome2_schemas_savelist
  28. }
  29. pkg_postinst() {
  30. gnome2_icon_cache_update
  31. gnome2_gconf_install
  32. gnome2_schemas_update
  33. }
  34. pkg_postrm() {
  35. gnome2_icon_cache_update
  36. }