logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

tootle-0.2.0.ebuild (750B)


  1. # Copyright 1999-2018 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit meson vala gnome2-utils
  5. DESCRIPTION="GTK3 client for Mastodon API"
  6. HOMEPAGE="https://github.com/bleakgrey/tootle"
  7. SRC_URI="https://github.com/bleakgrey/tootle/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. DEPEND="
  13. dev-libs/glib
  14. dev-libs/granite
  15. dev-libs/json-glib
  16. net-libs/libsoup:2.4
  17. x11-libs/gtk+:3
  18. "
  19. RDEPEND="${DEPEND}"
  20. src_prepare() {
  21. vala_src_prepare
  22. default
  23. }
  24. pkg_preinst() {
  25. gnome2_gconf_savelist
  26. gnome2_schemas_savelist
  27. }
  28. pkg_postinst() {
  29. gnome2_icon_cache_update
  30. gnome2_gconf_install
  31. gnome2_schemas_update
  32. }
  33. pkg_postrm() {
  34. gnome2_icon_cache_update
  35. }