logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

poezio-9999.ebuild (1454B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{6,7} )
  5. inherit distutils-r1 readme.gentoo-r1
  6. DESCRIPTION="Console XMPP client that looks like most famous IRC clients"
  7. HOMEPAGE="https://poez.io/"
  8. LICENSE="ZLIB"
  9. SLOT="0"
  10. IUSE="autoaway mpd otr test"
  11. RESTRICT="!test? ( test )"
  12. REQUIRE_USE="test? ( autoaway otr )"
  13. if [[ "${PV}" == "9999" ]]; then
  14. EGIT_REPO_URI="https://lab.louiz.org/${PN}/${PN}.git"
  15. inherit git-r3
  16. else
  17. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  18. KEYWORDS="~amd64"
  19. fi
  20. RDEPEND="
  21. dev-python/aiodns[${PYTHON_USEDEP}]
  22. dev-python/pyasn1-modules[${PYTHON_USEDEP}]
  23. dev-python/pyasn1[${PYTHON_USEDEP}]
  24. dev-python/slixmpp[${PYTHON_USEDEP}]
  25. autoaway? ( dev-python/pyinotify )
  26. otr? ( dev-python/potr )
  27. mpd? ( dev-python/python-mpd )
  28. "
  29. DEPEND="
  30. test? (
  31. ${RDEPEND}
  32. dev-python/potr
  33. dev-python/pyinotify
  34. )"
  35. DOC_CONTENTS="
  36. Install these optional runtime dependencies for additional features.
  37. * dev-python/potr for OTR encryption support.
  38. * dev-python/pyinotify for screen autoaway plugin support.
  39. * dev-python/python-mpd for mpd (music player daemon) support.
  40. * dev-python/pygments for code highlight support.
  41. * app-misc/figlet for ASCII Art support.
  42. "
  43. DISABLE_AUTOFORMATTING=true
  44. src_install() {
  45. distutils-r1_src_install
  46. readme.gentoo_create_doc
  47. }
  48. pkg_postinst() {
  49. readme.gentoo_print_elog
  50. }
  51. python_test() {
  52. esetup.py test
  53. }