logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

poezio-0.12.1.ebuild (1310B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. # also python3_8 compatible but deps in gentoo aren't so makes repoman frown
  5. PYTHON_COMPAT=( python3_{6,7} )
  6. inherit distutils-r1 readme.gentoo-r1
  7. DESCRIPTION="Console XMPP client that looks like most famous IRC clients"
  8. HOMEPAGE="https://poez.io/"
  9. LICENSE="ZLIB"
  10. SLOT="0"
  11. IUSE="test"
  12. RESTRICT="!test? ( test )"
  13. if [[ "${PV}" == "9999" ]]; then
  14. EGIT_REPO_URI="https://lab.louiz.org/${PN}/${PN}.git"
  15. inherit git-r3
  16. else
  17. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  18. KEYWORDS="~amd64"
  19. fi
  20. RDEPEND="
  21. dev-python/aiodns[${PYTHON_USEDEP}]
  22. dev-python/pyasn1-modules[${PYTHON_USEDEP}]
  23. dev-python/pyasn1[${PYTHON_USEDEP}]
  24. dev-python/slixmpp[${PYTHON_USEDEP}]
  25. "
  26. DEPEND="
  27. test? (
  28. ${RDEPEND}
  29. dev-python/potr
  30. dev-python/pyinotify
  31. dev-python/python-mpd
  32. )"
  33. DOC_CONTENTS="
  34. Install these optional runtime dependencies for additional features.
  35. * dev-python/potr for OTR encryption support.
  36. * dev-python/pyinotify for screen autoaway plugin support.
  37. * dev-python/python-mpd for music player daemon support.
  38. "
  39. DISABLE_AUTOFORMATTING=true
  40. src_install() {
  41. distutils-r1_src_install
  42. readme.gentoo_create_doc
  43. }
  44. pkg_postinst() {
  45. readme.gentoo_print_elog
  46. }
  47. python_test() {
  48. esetup.py test
  49. }