logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gajim-1.0.3.ebuild (625B)


  1. # Copyright 2018 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{5,6,7} )
  5. inherit distutils-r1
  6. DESCRIPTION="A GTK+ Jabber client"
  7. HOMEPAGE="https://gajim.org"
  8. KEYWORDS="~amd64"
  9. SRC_URI="https://gajim.org/downloads/1.0/${P}.tar.bz2"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. IUSE="webp gpg idn"
  13. RDEPENDS="
  14. dev-python/keyring
  15. >=dev-python/python-nbxmpp-0.6.7
  16. >=dev-python/pyopenssl-0.12
  17. >=dev-python/cssutils-1.0.2
  18. webp? ( dev-python/pillow )
  19. gpg? ( dev-python/python-gnupg )
  20. idn? (
  21. dev-python/idna
  22. dev-python/precis-i18n
  23. )
  24. "