logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

ldns-utils-1.7.0-r1.ebuild (1272B)


  1. # Copyright 1999-2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MY_P=${P/-utils}
  5. DESCRIPTION="Set of utilities to simplify various dns(sec) tasks"
  6. HOMEPAGE="https://www.nlnetlabs.nl/projects/ldns/"
  7. SRC_URI="https://www.nlnetlabs.nl/downloads/ldns/${MY_P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
  11. IUSE="+dane ecdsa examples gost ssl"
  12. REQUIRED_USE="
  13. ecdsa? ( ssl )
  14. dane? ( ssl )
  15. gost? ( ssl )
  16. "
  17. DEPEND=">=net-libs/ldns-${PV}[dane?,ecdsa?,gost?]
  18. examples? ( net-libs/libpcap )"
  19. RDEPEND="${DEPEND}"
  20. S=${WORKDIR}/${MY_P}
  21. PATCHES=( "${FILESDIR}/${P}_libressl.patch" )
  22. src_configure() {
  23. cd "${S}"/drill || die
  24. econf $(use_with ssl)
  25. if use examples; then
  26. cd "${S}"/examples || die
  27. econf \
  28. $(use_enable dane) \
  29. $(use_enable ecdsa) \
  30. $(use_enable gost) \
  31. $(use_enable ssl sha2) \
  32. $(use_with ssl)
  33. fi
  34. }
  35. src_compile() {
  36. emake -C drill
  37. if use examples; then
  38. emake -C examples
  39. fi
  40. }
  41. src_install() {
  42. cd "${S}"/drill || die
  43. emake DESTDIR="${D}" install
  44. dodoc ChangeLog.22-nov-2005 README REGRESSIONS
  45. if use examples; then
  46. cd "${S}"/examples || die
  47. emake DESTDIR="${D}" install
  48. newdoc README README.examples
  49. fi
  50. }