logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

shim-9999.ebuild (947B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. if [ "${PV}" = 9999 ]; then
  5. inherit git-r3
  6. EGIT_REPO_URI="https://git.sr.ht/~rabbits/shim"
  7. SLOT="0"
  8. else
  9. EGIT_COMMIT="4248690cecc249ab825753bae6ce25c7f4ac4cd1"
  10. MY_P="${PN}-${EGIT_COMMIT}"
  11. SRC_URI="https://git.sr.ht/~rabbits/shim/archive/${EGIT_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
  12. S="${WORKDIR}/${MY_P}"
  13. SLOT="0/${PV}"
  14. KEYWORDS="~amd64 ~arm64"
  15. fi
  16. DESCRIPTION="Pipe 3-bytes packets (channel, note, velocity) to a MIDI device"
  17. HOMEPAGE="https://git.sr.ht/~rabbits/shim/"
  18. LICENSE="MIT"
  19. SLOT="0"
  20. RDEPEND="media-libs/portmidi"
  21. DEPEND="${RDEPEND}"
  22. src_compile() {
  23. # ./build.sh ignores CC and compiler flags (CFLAGS, LDFLAGS, …) making it unsuitable
  24. # portmidi lacks a pkg-config file
  25. "${CC:-cc}" -std=c89 ${CFLAGS} shim.c -o shim -lportmidi || die
  26. }
  27. src_install() {
  28. einstalldocs
  29. dobin shim
  30. }