logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

oss-4.2.9999.ebuild (833B)


  1. # Copyright 2020 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit git-r3
  5. DESCRIPTION="Open Sound System (OSS)"
  6. HOMEPAGE="http://www.opensound.com/"
  7. EGIT_REPO_URI="https://git.code.sf.net/p/opensound/git"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS=""
  11. DEPENDS="x11-libs/gtk+:2"
  12. RDEPENDS="${DEPENDS}"
  13. src_prepare() {
  14. default
  15. mkdir "${S}_build" || die "Failed creating empty build directory"
  16. }
  17. src_configure() {
  18. cd "${S}_build" || die "Failed changing to build directory"
  19. "${S}/configure" --enable-libsalsa=NO || die "Failed running ./configure"
  20. }
  21. src_compile() {
  22. cd "${S}_build" || die "Failed changing to build directory"
  23. emake build
  24. }
  25. src_install() {
  26. cd "${S}_build" || die "Failed changing to build directory"
  27. emake DESTDIR="${D}/" copy
  28. }