logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

oss-4.2.2019.ebuild (1032B)


  1. # Copyright 2020 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. MY_P="oss-v$(ver_cut 1-2)-build$(ver_cut 3)-src-gpl"
  5. DESCRIPTION="Open Sound System (OSS)"
  6. HOMEPAGE="http://www.opensound.com/"
  7. SRC_URI="http://www.opensound.com/developer/sources/stable/gpl/${MY_P}.tar.bz2"
  8. S="${WORKDIR}/${MY_P}"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS=""
  12. DEPENDS="x11-libs/gtk+:2"
  13. RDEPENDS="${DEPENDS}"
  14. PATCHES=(
  15. "${FILESDIR}/oss-4.2.2019_sysmacros.patch"
  16. "${FILESDIR}/oss-4.2.2019_no_compressed_manpages.patch"
  17. )
  18. src_prepare() {
  19. default
  20. mkdir "${S}_build" || die "Failed creating empty build directory"
  21. }
  22. src_configure() {
  23. cd "${S}_build" || die "Failed changing to build directory"
  24. "${S}/configure" --enable-libsalsa=NO || die "Failed running ./configure"
  25. }
  26. src_compile() {
  27. cd "${S}_build" || die "Failed changing to build directory"
  28. emake build
  29. }
  30. src_install() {
  31. cd "${S}_build" || die "Failed changing to build directory"
  32. emake DESTDIR="${D}/" copy
  33. }