logo

overlay

My own overlay for experimentations, use with caution, no support is provided

milkytracker-1.02.00.ebuild (1175B)


      1 # Copyright 1999-2019 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit cmake-utils desktop
      7 
      8 DESCRIPTION="FastTracker 2 inspired music tracker"
      9 HOMEPAGE="https://milkytracker.titandemo.org/"
     10 SRC_URI="https://github.com/milkytracker/MilkyTracker/archive/v${PV}.tar.gz -> ${P}.tar.gz"
     11 
     12 LICENSE="|| ( GPL-3 MPL-1.1 ) AIFFWriter.m BSD GPL-3 GPL-3+ LGPL-2.1+ MIT"
     13 SLOT="0"
     14 KEYWORDS="~amd64 ~x86"
     15 IUSE="alsa jack"
     16 
     17 RDEPEND="
     18 	dev-libs/zziplib
     19 	media-libs/libsdl2[X]
     20 	sys-libs/zlib
     21 	alsa? ( media-libs/alsa-lib )
     22 	jack? ( media-sound/jack-audio-connection-kit )"
     23 DEPEND="${RDEPEND}"
     24 
     25 PATCHES=(
     26 	"${FILESDIR}/${P}-clang-6.0.0-fix.patch"
     27 	"${FILESDIR}/${P}-EQConstants.cpp.patch"
     28 	"${FILESDIR}/${P}-fix_FindSDL2.cmake.patch"
     29 )
     30 
     31 S="${WORKDIR}/MilkyTracker-${PV}"
     32 
     33 src_configure() {
     34 	local mycmakeargs=(
     35 		-DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
     36 		$(cmake-utils_use_find_package alsa ALSA)
     37 		$(cmake-utils_use_find_package jack JACK)
     38 	)
     39 	cmake-utils_src_configure
     40 }
     41 
     42 src_install() {
     43 	cmake-utils_src_install
     44 
     45 	newicon resources/pictures/carton.png ${PN}.png
     46 	make_desktop_entry ${PN} MilkyTracker ${PN} \
     47 		"AudioVideo;Audio;Sequencer"
     48 }