logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

aucatctl-0.1.ebuild (610B)


  1. # Copyright 2020 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. DESCRIPTION="A tool for controlling aucat and/or sndiod volume through MIDI"
  5. HOMEPAGE="http://www.sndio.org/"
  6. SRC_URI="http://www.sndio.org/${P}.tar.gz"
  7. LICENSE="ISC"
  8. SLOT="0/7.0"
  9. KEYWORDS="~amd64"
  10. DEPEND="
  11. dev-libs/libbsd
  12. media-sound/sndio
  13. "
  14. RDEPEND="${DEPEND}"
  15. src_prepare() {
  16. default
  17. sed -i \
  18. -e 's?/usr/local?/usr?g' \
  19. -e 's?man/man1?share/man/man1?g' \
  20. -e 's?LDADD = -lsndio?LDADD = -lbsd -lsndio?' \
  21. Makefile || die "Failed modifying Makefile"
  22. }