logo

overlay

My own overlay for experimentations, use with caution, no support is provided

gst-plugins-v4l2-1.18.0.ebuild (658B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GST_ORG_MODULE=gst-plugins-good
  5. inherit gstreamer-meson
  6. DESCRIPION="V4L2 source/sink plugin for GStreamer"
  7. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
  8. IUSE="udev"
  9. RDEPEND="
  10. >=media-libs/libv4l-0.9.5[${MULTILIB_USEDEP}]
  11. >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
  12. udev? ( >=dev-libs/libgudev-208:=[${MULTILIB_USEDEP}] )
  13. "
  14. DEPEND="${RDEPEND}
  15. virtual/os-headers
  16. "
  17. multilib_src_configure() {
  18. local emesonargs=(
  19. $(meson_feature udev v4l2-gudev)
  20. )
  21. gstreamer_multilib_src_configure
  22. }