logo

overlay

My own overlay for experimentations, use with caution, no support is provided

gst-plugins-sndio-1.8.0.1.ebuild (640B)


      1 # Copyright 2020 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 MY_P="gstreamer1-plugins-sndio-${PV}"
      7 
      8 DESCRIPTION="Sndio audio sink and source for GStreamer"
      9 HOMEPAGE="https://github.com/t6/gstreamer1-plugins-sndio"
     10 SRC_URI="https://github.com/t6/gstreamer1-plugins-sndio/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
     11 S="${WORKDIR}/${MY_P}"
     12 LICENSE="ISC"
     13 SLOT="0"
     14 KEYWORDS="~amd64"
     15 
     16 DEPEND="
     17 	media-libs/gstreamer:1.0
     18 	media-sound/sndio:=
     19 	sys-devel/gettext
     20 	dev-libs/glib
     21 "
     22 RDEPEND="${DEPEND}"
     23 
     24 src_install() {
     25 	export BSD_INSTALL_LIB="install -m 444"
     26 
     27 	default
     28 }