logo

overlay

My own overlay for experimentations, use with caution, no support is provided

gst-plugins-libav-1.18.0.ebuild (1038B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gstreamer-meson multilib-minimal
  5. MY_PN="gst-libav"
  6. MY_PV="$(ver_cut 1-3)"
  7. MY_P="${MY_PN}-${MY_PV}"
  8. FFMPEG_PV="$(ver_cut 4- ${PV%_*})"
  9. DESCRIPTION="FFmpeg based gstreamer plugin"
  10. HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-libav.html"
  11. SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_P}.tar.xz"
  12. LICENSE="LGPL-2+"
  13. SLOT="1.0"
  14. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86"
  15. IUSE="+orc"
  16. RDEPEND="
  17. >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
  18. >=media-libs/gstreamer-${MY_PV}:1.0[${MULTILIB_USEDEP}]
  19. >=media-libs/gst-plugins-base-${MY_PV}:1.0[${MULTILIB_USEDEP}]
  20. >=media-video/ffmpeg-4:0=[${MULTILIB_USEDEP}]
  21. orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
  22. "
  23. DEPEND="${RDEPEND}
  24. >=dev-util/gtk-doc-am-1.12
  25. >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
  26. "
  27. S="${WORKDIR}/${MY_P}"
  28. RESTRICT="test" # FIXME: tests seem to get stuck at one point; investigate properly