logo

overlay

My own overlay for experimentations, use with caution, no support is provided

gst-plugins-libav-1.16.2.ebuild (1513B)


      1 # Copyright 1999-2020 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=6
      5 
      6 inherit autotools eapi7-ver multilib-minimal
      7 
      8 MY_PN="gst-libav"
      9 MY_PV="$(ver_cut 1-3)"
     10 MY_P="${MY_PN}-${MY_PV}"
     11 FFMPEG_PV="$(ver_cut 4- ${PV%_*})"
     12 
     13 DESCRIPTION="FFmpeg based gstreamer plugin"
     14 HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-libav.html"
     15 SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_P}.tar.xz"
     16 
     17 LICENSE="LGPL-2+"
     18 SLOT="1.0"
     19 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86"
     20 IUSE="+orc"
     21 
     22 RDEPEND="
     23 	>=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
     24 	>=media-libs/gstreamer-${MY_PV}:1.0[${MULTILIB_USEDEP}]
     25 	>=media-libs/gst-plugins-base-${MY_PV}:1.0[${MULTILIB_USEDEP}]
     26 	>=media-video/ffmpeg-4:0=[${MULTILIB_USEDEP}]
     27 	orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
     28 "
     29 DEPEND="${RDEPEND}
     30 	>=dev-util/gtk-doc-am-1.12
     31 	>=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
     32 "
     33 
     34 S="${WORKDIR}/${MY_P}"
     35 
     36 RESTRICT="test" # FIXME: tests seem to get stuck at one point; investigate properly
     37 
     38 multilib_src_configure() {
     39 	GST_PLUGINS_BUILD=""
     40 
     41 	ECONF_SOURCE=${S} \
     42 	econf \
     43 		--disable-maintainer-mode \
     44 		--with-package-name="Gentoo GStreamer ebuild" \
     45 		--with-package-origin="https://www.gentoo.org" \
     46 		--disable-fatal-warnings \
     47 		--with-system-libav \
     48 		$(use_enable orc)
     49 }
     50 
     51 multilib_src_compile() {
     52 	# Don't build with -Werror; verbose build
     53 	emake ERROR_CFLAGS= V=1
     54 }
     55 
     56 multilib_src_install_all() {
     57 	einstalldocs
     58 	find "${ED}" -name '*.la' -delete || die
     59 }