logo

overlay

My own overlay for experimentations, use with caution, no support is provided

gst-plugins-hls-1.16.2.ebuild (1122B)


      1 # Copyright 1999-2020 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=6
      5 GST_ORG_MODULE=gst-plugins-bad
      6 
      7 inherit gstreamer
      8 
      9 DESCRIPTION="HTTP live streaming plugin for GStreamer"
     10 KEYWORDS="~amd64 ~x86"
     11 IUSE=""
     12 
     13 RDEPEND="
     14 	dev-libs/nettle:0=[${MULTILIB_USEDEP}]
     15 "
     16 DEPEND="${RDEPEND}"
     17 
     18 src_prepare() {
     19 	default
     20 
     21 	# FIXME: gsturidownloader does not have a .pc
     22 	# gstreamer_system_link \
     23 	#	gst-libs/gst/uridownloader:gsturidownloader \
     24 	#	gst-libs/gst/adaptativedemux:gstadaptivedemux
     25 
     26 	local directory libs
     27 	directory="gst-libs/gst/uridownloader"
     28 	libs="-lgobject-2.0 -lglib-2.0 -lgstreamer-1.0 -lgstbase-1.0 -lgsturidownloader-1.0"
     29 	sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
     30 		-i ext/hls/Makefile.{am,in} || die
     31 
     32 	directory="gst-libs/gst/adaptivedemux"
     33 	libs="-lgobject-2.0 -lglib-2.0 -lgstreamer-1.0 -lgstbase-1.0 -lgstapp-1.0 -lgsturidownloader-1.0 -lgstadaptivedemux-1.0"
     34 	sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
     35 		-i ext/hls/Makefile.{am,in} || die
     36 }
     37 
     38 multilib_src_configure() {
     39 	gstreamer_multilib_src_configure \
     40 		--with-hls-crypto=nettle
     41 }