logo

overlay

My own overlay for experimentations, use with caution, no support is provided

gst-plugins-dash-1.16.2.ebuild (1267B)


      1 # Copyright 1999-2020 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=6
      5 GST_ORG_MODULE=gst-plugins-bad
      6 
      7 inherit gstreamer
      8 
      9 DESCRIPTION="MPEG-DASH plugin for GStreamer"
     10 KEYWORDS="~amd64 ~x86"
     11 IUSE=""
     12 
     13 RDEPEND=">=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]"
     14 DEPEND="${RDEPEND}"
     15 
     16 src_prepare() {
     17 	default
     18 
     19 	# FIXME: gsturidownloader does not have a .pc
     20 	# gstreamer_system_link \
     21 	#	gst-libs/gst/uridownloader:gsturidownloader \
     22 	#	gst-libs/gst/adaptivedemux:gstadaptivedemux \
     23 	#	gst-libs/gst/isoff:gstisoff
     24 
     25 	local directory libs
     26 	directory="gst-libs/gst/uridownloader"
     27 	libs="-lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lgsturidownloader-1.0"
     28 	sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
     29 		-i ext/dash/Makefile.{am,in} || die
     30 
     31 	directory="gst-libs/gst/adaptivedemux"
     32 	libs="-lgsturidownloader-1.0 -lgstapp-1.0 -lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lgstadaptivedemux-1.0"
     33 	sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
     34 		-i ext/dash/Makefile.{am,in} || die
     35 
     36 	directory="gst-libs/gst/isoff"
     37 	libs="-lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -lgstisoff-1.0"
     38 	sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
     39 		-i ext/dash/Makefile.{am,in} || die
     40 }