logo

overlay

My own overlay for experimentations, use with caution, no support is provided

alsa-sndio-0.2.ebuild (621B)


      1 # Copyright 2020 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 DESCRIPTION="Sndio audio sink and source for GStreamer"
      7 HOMEPAGE="https://github.com/Duncaen/alsa-sndio"
      8 SRC_URI="https://github.com/Duncaen/alsa-sndio/archive/${PV}.tar.gz -> ${P}.tar.gz"
      9 LICENSE="ISC"
     10 SLOT="0"
     11 KEYWORDS="~amd64"
     12 
     13 DEPEND="
     14 	media-libs/alsa-lib
     15 	media-sound/sndio:=
     16 "
     17 RDEPEND="${DEPEND}"
     18 
     19 src_prepare() {
     20 	default
     21 
     22 	sed -i "s;/lib/alsa-lib/;/$(get_libdir)/alsa-lib/;" Makefile || die "Failed changing libdir"
     23 }
     24 
     25 src_install() {
     26 	export PREFIX="/usr"
     27 
     28 	default
     29 }