logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

x264-0.0.20170701.ebuild (1664B)


  1. # Copyright 1999-2018 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit flag-o-matic multilib-minimal toolchain-funcs
  5. DESCRIPTION="A free library for encoding X264/AVC streams"
  6. HOMEPAGE="https://www.videolan.org/developers/x264.html"
  7. if [[ ${PV} == 9999 ]]; then
  8. inherit git-r3
  9. EGIT_REPO_URI="https://git.videolan.org/git/x264.git"
  10. else
  11. inherit versionator
  12. MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
  13. SRC_URI="https://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
  14. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos "
  15. S="${WORKDIR}/${MY_P}"
  16. fi
  17. SONAME="152"
  18. SLOT="0/${SONAME}"
  19. LICENSE="GPL-2"
  20. IUSE="10bit altivec asm +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
  21. ASM_DEP=">=dev-lang/nasm-2.13"
  22. DEPEND="abi_x86_32? ( ${ASM_DEP} )
  23. abi_x86_64? ( ${ASM_DEP} )
  24. opencl? ( dev-lang/perl )"
  25. RDEPEND="opencl? ( >=virtual/opencl-0-r3[${MULTILIB_USEDEP}] )"
  26. DOCS=( AUTHORS doc/{ratecontrol,regression_test,standards,threads,vui}.txt )
  27. multilib_src_configure() {
  28. tc-export CC
  29. "${S}/configure" \
  30. --prefix="${EPREFIX}"/usr \
  31. --libdir="${EPREFIX}"/usr/$(get_libdir) \
  32. --disable-cli \
  33. --disable-avs \
  34. --disable-lavf \
  35. --disable-swscale \
  36. --disable-ffms \
  37. --disable-gpac \
  38. --enable-pic \
  39. --enable-shared \
  40. --host="${CHOST}" \
  41. $(usex 10bit "--bit-depth=10" "") \
  42. $(usex interlaced "" "--disable-interlaced") \
  43. $(usex opencl "" "--disable-opencl") \
  44. $(usex static-libs "--enable-static" "") \
  45. $(usex threads "" "--disable-thread") \
  46. $(use_enable asm)
  47. }