logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

smpeg2-2.0.0_p20230817.ebuild (1171B)


  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit autotools multilib-minimal
  5. EGIT_COMMIT="868a1e43a69044cd6f346ab897da557c59d11c8c"
  6. DESCRIPTION="SDL MPEG Player Library"
  7. HOMEPAGE="https://icculus.org/smpeg/ https://github.com/icculus/smpeg"
  8. SRC_URI="https://github.com/icculus/smpeg/archive/${EGIT_COMMIT}.tar.gz -> ${PN}-${EGIT_COMMIT}.tar.gz"
  9. S="${WORKDIR}/smpeg-${EGIT_COMMIT}"
  10. LICENSE="LGPL-2+"
  11. SLOT="0"
  12. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
  13. IUSE="cpu_flags_x86_mmx"
  14. DEPEND="media-libs/libsdl2[${MULTILIB_USEDEP}]"
  15. RDEPEND="${DEPEND}"
  16. src_prepare() {
  17. default
  18. # avoid file collision with media-libs/smpeg
  19. sed -i -e '/plaympeg/d' Makefile.am || die
  20. AT_M4DIR="${ESYSROOT}/usr/share/aclocal acinclude" eautoreconf
  21. }
  22. multilib_src_configure() {
  23. local myeconfargs=(
  24. --disable-rpath
  25. --disable-sdltest
  26. --enable-debug # disabling this only passes extra optimizations
  27. $(use_enable cpu_flags_x86_mmx mmx)
  28. )
  29. ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
  30. }
  31. multilib_src_install_all() {
  32. einstalldocs
  33. find "${ED}" -name '*.la' -delete || die
  34. }