logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

portsmf-239.ebuild (605B)


  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit cmake
  5. DESCRIPTION="Portable library for reading/writing Standard MIDI Files"
  6. HOMEPAGE="https://github.com/tenacityteam/portsmf"
  7. SRC_URI="https://github.com/tenacityteam/portsmf/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="examples test"
  12. RESTRICT="!test? ( test )"
  13. PATCHES=( "${FILESDIR}/${P}-ctest.patch" )
  14. src_configure() {
  15. local mycmakeargs=(
  16. -DBUILD_APPS=$(usex examples)
  17. -DBUILD_TESTING=$(usex test)
  18. )
  19. cmake_src_configure
  20. }