logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

portmidi-2.0.4.ebuild (957B)


  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit cmake
  5. DESCRIPTION="Library for real time MIDI input and output"
  6. HOMEPAGE="http://portmedia.sourceforge.net/"
  7. SRC_URI="https://github.com/PortMidi/portmidi/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="doc test-programs"
  12. RDEPEND="media-libs/alsa-lib"
  13. DEPEND="
  14. ${RDEPEND}
  15. doc? ( app-doc/doxygen )
  16. "
  17. src_prepare() {
  18. cmake_src_prepare
  19. mkdir docs || die
  20. sed -i \
  21. -e 's;^OUTPUT_DIRECTORY\b.*;OUTPUT_DIRECTORY = docs;' \
  22. -e 's;^HTML_OUTPUT\b.*;HTML_OUTPUT = html;' \
  23. Doxyfile || die
  24. }
  25. src_configure() {
  26. #CMAKE_BUILD_TYPE=RelWithDebInfo
  27. local mycmakeargs=(
  28. -DBUILD_PORTMIDI_TESTS=$(usex test-programs)
  29. )
  30. cmake_src_configure
  31. }
  32. src_compile() {
  33. cmake_src_compile
  34. if use doc; then doxygen || die; fi
  35. }
  36. src_install() {
  37. cmake_src_install
  38. use doc && dodoc -r docs/html
  39. }