logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

portaudio-19.06.00-r3.ebuild (1926B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit autotools multilib-minimal
  5. DESCRIPTION="A free, cross-platform, open-source, audio I/O library"
  6. HOMEPAGE="http://www.portaudio.com/"
  7. SRC_URI="http://www.portaudio.com/archives/pa_stable_v190600_20161030.tgz
  8. https://sources.debian.org/data/main/p/portaudio19/19.6.0-1/debian/patches/audacity-portmixer.patch -> ${PN}-19.06.00-audacity-portmixer.patch"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
  12. IUSE="alsa +cxx debug doc jack oss sndio static-libs"
  13. RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
  14. jack? ( virtual/jack[${MULTILIB_USEDEP}] )
  15. sndio? ( media-sound/sndio:=[${MULTILIB_USEDEP}] )
  16. "
  17. DEPEND="${RDEPEND}"
  18. BDEPEND="
  19. doc? ( app-doc/doxygen )
  20. virtual/pkgconfig
  21. "
  22. S="${WORKDIR}/${PN}"
  23. DOCS=( README.txt )
  24. PATCHES=(
  25. "${DISTDIR}/${PN}-19.06.00-audacity-portmixer.patch"
  26. "${FILESDIR}"/${PN}-19.06.00-AR.patch # bug #720966, trigger reconf
  27. "${FILESDIR}/${PN}-19.06.00-sndio.patch"
  28. )
  29. src_prepare() {
  30. default
  31. mkdir -p "${S}/src/hostapi/sndio/" || die
  32. cp "${FILESDIR}/${PN}-19.06.00-pa_sndio.c" "${S}/src/hostapi/sndio/pa_sndio.c" || die
  33. eautoconf
  34. multilib_copy_sources
  35. }
  36. multilib_src_configure() {
  37. local myeconfargs=(
  38. $(use_enable debug debug-output)
  39. $(use_enable cxx)
  40. $(use_enable static-libs static)
  41. $(use_with alsa)
  42. $(use_with jack)
  43. $(use_with oss)
  44. $(use_with sndio)
  45. )
  46. ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
  47. }
  48. multilib_src_compile() {
  49. # workaround parallel build issue
  50. emake lib/libportaudio.la
  51. emake
  52. }
  53. src_compile() {
  54. multilib-minimal_src_compile
  55. if use doc; then
  56. doxygen -u Doxyfile || die
  57. doxygen Doxyfile || die
  58. fi
  59. }
  60. multilib_src_install_all() {
  61. einstalldocs
  62. use doc && dodoc -r doc/html
  63. find "${ED}" -name "*.la" -delete || die
  64. }