logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

openxr-loader-9999.ebuild (691B)


  1. # Copyright 2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. MY_PN=OpenXR-SDK
  5. inherit cmake
  6. if [[ ${PV} == *9999* ]]; then
  7. EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
  8. inherit git-r3
  9. else
  10. SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
  11. KEYWORDS="~amd64"
  12. S="${WORKDIR}"/${MY_PN}-${PV}
  13. fi
  14. DESCRIPTION="OpenXR loader"
  15. HOMEPAGE="https://github.com/KhronosGroup/OpenXR-SDK"
  16. LICENSE="Apache-2.0"
  17. SLOT="0"
  18. BDEPEND=">=dev-util/cmake-3.10.2"
  19. DEPEND="
  20. media-libs/vulkan-loader
  21. x11-libs/libxcb
  22. x11-libs/xcb-util-keysyms
  23. x11-libs/libXrandr
  24. x11-libs/libXxf86vm
  25. media-libs/mesa
  26. "