logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

monado-9999.ebuild (610B)


  1. # Copyright 2020 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit cmake git-r3
  5. DESCRIPTION="The open source OpenXR runtime."
  6. HOMEPAGE="https://monado.dev"
  7. EGIT_REPO_URI="https://gitlab.freedesktop.org/monado/monado.git"
  8. LICENSE="Boost-1.0"
  9. SLOT="0"
  10. # TODO: OpenHMD
  11. BDEPEND=""
  12. DEPEND="
  13. media-libs/openxr-loader
  14. media-libs/mesa
  15. dev-cpp/eigen:3
  16. dev-util/glslang
  17. virtual/libusb
  18. virtual/libudev
  19. media-libs/libv4l
  20. "
  21. RDEPEND="${DEPEND}"
  22. src_configure() {
  23. local ecmakeargs=(
  24. -DSYSTEM_CJSON=ON
  25. )
  26. cmake_src_configure
  27. }