logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libvgm-0_pre20230814.ebuild (788B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit cmake
  5. DESCRIPTION="more modular rewrite of most components from VGMPlay"
  6. HOMEPAGE="https://github.com/ValleyBell/libvgm"
  7. EGIT_COMMIT="91b6542a25a754f985181921331bdcbb2699c03c"
  8. SRC_URI="https://github.com/ValleyBell/libvgm/archive/${EGIT_COMMIT}.tar.gz -> libvgm-${EGIT_COMMIT}.tar.gz"
  9. S="${WORKDIR}/libvgm-${EGIT_COMMIT}"
  10. # Maybe a bit more complex than that given GPL-2 code so bindist https://github.com/ValleyBell/libvgm/issues/43
  11. LICENSE="all-rights-reserved GPL-2"
  12. SLOT="0"
  13. KEYWORDS="~amd64"
  14. RESTRICT="bindist"
  15. # FIXME: Configure cmake enough to avoid automagic
  16. DEPEND="
  17. media-libs/alsa-lib
  18. sys-libs/zlib
  19. "
  20. RDEPEND="${DEPEND}"