logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libsdl-9999.ebuild (1170B)


  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit cmake-multilib
  5. if [ "${PV}" = "9999" ]; then
  6. inherit git-r3
  7. EGIT_REPO_URI="https://github.com/libsdl-org/sdl12-compat"
  8. else
  9. SRC_URI="https://github.com/libsdl-org/sdl12-compat/archive/refs/tags/release-${PV}.tar.gz"
  10. S="${WORKDIR}/sdl12-compat-release-${PV}"
  11. KEYWORDS="~amd64 ~x86"
  12. fi
  13. DESCRIPTION="Simple Direct Media Layer (sdl-1.2 compatibility)"
  14. HOMEPAGE="https://github.com/libsdl-org/sdl12-compat"
  15. # dr_mp3: MIT-O or Unlicense
  16. LICENSE="ZLIB || ( MIT-0 Unlicense )"
  17. SLOT="0"
  18. RESTRICT="!test? ( test )"
  19. # First line are fakes and just there for compat with other ebuilds
  20. IUSE="
  21. oss alsa nas X dga xv xinerama fbcon tslib aalib opengl libcaca +sound +video +joystick custom-cflags pulseaudio static-libs
  22. test
  23. "
  24. # IUSE inheritance dropped: dga, xv, fbcon, tflib, aalib, libcaca, custom-cflags, static-libs, X
  25. DEPEND="
  26. media-libs/libsdl2[oss?,alsa?,nas?,xinerama(+)?,opengl?,sound?,video?,joystick?,pulseaudio?]
  27. "
  28. RDEPEND="${DEPEND}"
  29. src_configure() {
  30. local mycmakeargs=(
  31. -DSDL12TESTS=$(usex test)
  32. )
  33. cmake-multilib_src_configure
  34. }