logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gstreamer-1.18.4.ebuild (2725B)


  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit gstreamer-meson bash-completion-r1 pax-utils
  5. DESCRIPTION="Open source multimedia framework"
  6. HOMEPAGE="https://gstreamer.freedesktop.org/"
  7. SRC_URI="https://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"
  8. LICENSE="LGPL-2+"
  9. SLOT="1.0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
  11. IUSE="+caps +introspection +orc unwind"
  12. RDEPEND="
  13. caps? ( sys-libs/libcap[${MULTILIB_USEDEP}] )
  14. introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
  15. unwind? (
  16. >=sys-libs/libunwind-1.2_rc1[${MULTILIB_USEDEP}]
  17. dev-libs/elfutils[${MULTILIB_USEDEP}]
  18. )
  19. !<media-libs/gst-plugins-bad-1.13.1:1.0
  20. "
  21. DEPEND="${RDEPEND}
  22. dev-util/glib-utils
  23. >=dev-util/gtk-doc-am-1.12
  24. sys-devel/bison
  25. sys-devel/flex
  26. "
  27. src_configure() {
  28. if [[ ${CHOST} == *-interix* ]] ; then
  29. export ac_cv_lib_dl_dladdr=no
  30. export ac_cv_func_poll=no
  31. fi
  32. if [[ ${CHOST} == powerpc-apple-darwin* ]] ; then
  33. # GCC groks this, but then refers to an implementation (___multi3,
  34. # ___udivti3) that don't exist (at least I can't find it), so force
  35. # this one to be off, such that we use 2x64bit emulation code.
  36. export gst_cv_uint128_t=no
  37. fi
  38. multilib-minimal_src_configure
  39. }
  40. multilib_src_configure() {
  41. local completiondir=$(get_bashcompdir)
  42. # Set 'libexecdir' to ABI-specific location for the library spawns
  43. # helpers from there.
  44. # Disable static archives and examples to speed up build time
  45. # Disable debug, as it only affects -g passing (debugging symbols), this must done through make.conf in gentoo
  46. local emesonargs=(
  47. -Dbenchmarks=enabled
  48. -Dcheck=enabled
  49. $(meson_feature unwind libunwind)
  50. $(meson_feature unwind libdw)
  51. )
  52. # -Dintrospection=$(multilib_native_usex introspection)
  53. if use caps ; then
  54. emesonargs+=( -Dptp-helper-permissions=capabilities )
  55. else
  56. emesonargs+=(
  57. -Dptp-helper-permissions=setuid-root
  58. -Dptp-helper-setuid-user=nobody
  59. -Dptp-helper-setuid-group=nobody
  60. )
  61. fi
  62. gstreamer_multilib_src_configure
  63. }
  64. multilib_src_install() {
  65. # can't do "default", we want to install docs in multilib_src_install_all
  66. DESTDIR="${D}" eninja install
  67. # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
  68. use orc && pax-mark -m "${ED}usr/$(get_libdir)/gstreamer-${SLOT}/gst-plugin-scanner"
  69. }
  70. multilib_src_install_all() {
  71. DOCS="AUTHORS ChangeLog NEWS MAINTAINERS README RELEASE"
  72. einstalldocs
  73. find "${ED}" -name '*.la' -delete || die
  74. # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
  75. use orc && pax-mark -m "${ED}usr/bin/gst-launch-${SLOT}"
  76. }