logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gstreamer-1.18.1.ebuild (2950B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gstreamer-meson bash-completion-r1 multilib-minimal pax-utils
  5. DESCRIPTION="Open source multimedia framework"
  6. HOMEPAGE="https://gstreamer.freedesktop.org/"
  7. SRC_URI="https://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"
  8. LICENSE="LGPL-2+"
  9. SLOT="1.0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
  11. IUSE="+caps +introspection nls +orc test unwind"
  12. RESTRICT="!test? ( test )"
  13. RDEPEND="
  14. >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
  15. caps? ( sys-libs/libcap[${MULTILIB_USEDEP}] )
  16. introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
  17. unwind? (
  18. >=sys-libs/libunwind-1.2_rc1[${MULTILIB_USEDEP}]
  19. dev-libs/elfutils[${MULTILIB_USEDEP}]
  20. )
  21. !<media-libs/gst-plugins-bad-1.13.1:1.0
  22. "
  23. DEPEND="${RDEPEND}
  24. dev-util/glib-utils
  25. >=dev-util/gtk-doc-am-1.12
  26. sys-devel/bison
  27. sys-devel/flex
  28. >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
  29. nls? ( sys-devel/gettext )
  30. "
  31. src_configure() {
  32. if [[ ${CHOST} == *-interix* ]] ; then
  33. export ac_cv_lib_dl_dladdr=no
  34. export ac_cv_func_poll=no
  35. fi
  36. if [[ ${CHOST} == powerpc-apple-darwin* ]] ; then
  37. # GCC groks this, but then refers to an implementation (___multi3,
  38. # ___udivti3) that don't exist (at least I can't find it), so force
  39. # this one to be off, such that we use 2x64bit emulation code.
  40. export gst_cv_uint128_t=no
  41. fi
  42. multilib-minimal_src_configure
  43. }
  44. multilib_src_configure() {
  45. local completiondir=$(get_bashcompdir)
  46. # Set 'libexecdir' to ABI-specific location for the library spawns
  47. # helpers from there.
  48. # Disable static archives and examples to speed up build time
  49. # Disable debug, as it only affects -g passing (debugging symbols), this must done through make.conf in gentoo
  50. local emesonargs=(
  51. -Dbenchmarks=enabled
  52. -Dgst_debug=false
  53. -Dcheck=enabled
  54. $(meson_feature unwind libunwind)
  55. $(meson_feature unwind libdw)
  56. $(meson_feature test tests)
  57. )
  58. # -Dintrospection=$(multilib_native_usex introspection)
  59. if use caps ; then
  60. emesonargs+=( -Dptp-helper-permissions=capabilities )
  61. else
  62. emesonargs+=(
  63. -Dptp-helper-permissions=setuid-root
  64. -Dptp-helper-setuid-user=nobody
  65. -Dptp-helper-setuid-group=nobody
  66. )
  67. fi
  68. meson_src_configure
  69. }
  70. multilib_src_install() {
  71. # can't do "default", we want to install docs in multilib_src_install_all
  72. DESTDIR="${D}" eninja install
  73. # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
  74. use orc && pax-mark -m "${ED}usr/$(get_libdir)/gstreamer-${SLOT}/gst-plugin-scanner"
  75. }
  76. multilib_src_install_all() {
  77. DOCS="AUTHORS ChangeLog NEWS MAINTAINERS README RELEASE"
  78. einstalldocs
  79. find "${ED}" -name '*.la' -delete || die
  80. # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
  81. use orc && pax-mark -m "${ED}usr/bin/gst-launch-${SLOT}"
  82. }