gst-plugins-ugly-1.18.4.ebuild (756B)
- # Copyright 1999-2021 Gentoo Authors
- # Distributed under the terms of the GNU General Public License v2
- EAPI=7
- GST_ORG_MODULE="gst-plugins-ugly"
- GST_PLUGINS_ENABLED="asfdemux dvdlpcmdec dvdsub realmedia xingmux"
- inherit gstreamer-meson
- DESCRIPTION="Basepack of plugins for gstreamer"
- HOMEPAGE="https://gstreamer.freedesktop.org/"
- LICENSE="LGPL-2+" # some split plugins are LGPL but combining with a GPL library
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
- RDEPEND="
- >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
- "
- DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.12
- "
- DOCS="AUTHORS ChangeLog NEWS README RELEASE"
- multilib_src_install_all() {
- einstalldocs
- find "${ED}" -name '*.la' -delete || die
- }