logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gst-plugins-ugly-1.18.4.ebuild (756B)


  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. GST_ORG_MODULE="gst-plugins-ugly"
  5. GST_PLUGINS_ENABLED="asfdemux dvdlpcmdec dvdsub realmedia xingmux"
  6. inherit gstreamer-meson
  7. DESCRIPTION="Basepack of plugins for gstreamer"
  8. HOMEPAGE="https://gstreamer.freedesktop.org/"
  9. LICENSE="LGPL-2+" # some split plugins are LGPL but combining with a GPL library
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
  11. RDEPEND="
  12. >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
  13. "
  14. DEPEND="${RDEPEND}
  15. >=dev-util/gtk-doc-am-1.12
  16. "
  17. DOCS="AUTHORS ChangeLog NEWS README RELEASE"
  18. multilib_src_install_all() {
  19. einstalldocs
  20. find "${ED}" -name '*.la' -delete || die
  21. }