gst-plugins-ugly-1.18.3.ebuild (781B)
- # Copyright 1999-2019 Gentoo Authors
- # Distributed under the terms of the GNU General Public License v2
- EAPI=6
- GST_ORG_MODULE="gst-plugins-ugly"
- GST_PLUGINS_ENABLED="asfdemux dvdlpcmdec dvdsub realmedia xingmux"
- inherit gstreamer-meson
- DESCRIPTION="Basepack of plugins for gstreamer"
- HOMEPAGE="https://gstreamer.freedesktop.org/"
- LICENSE="LGPL-2+" # some split plugins are LGPL but combining with a GPL library
- RDEPEND="
- >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
- >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
- >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
- "
- DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.12
- "
- multilib_src_install_all() {
- DOCS="AUTHORS ChangeLog NEWS README RELEASE"
- einstalldocs
- find "${ED}" -name '*.la' -delete || die
- }