logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gst-plugins-ugly-1.18.1.ebuild (781B)


  1. # Copyright 1999-2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GST_ORG_MODULE="gst-plugins-ugly"
  5. GST_PLUGINS_ENABLED="asfdemux dvdlpcmdec dvdsub realmedia xingmux"
  6. inherit gstreamer-meson
  7. DESCRIPTION="Basepack of plugins for gstreamer"
  8. HOMEPAGE="https://gstreamer.freedesktop.org/"
  9. LICENSE="LGPL-2+" # some split plugins are LGPL but combining with a GPL library
  10. RDEPEND="
  11. >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
  12. >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
  13. >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
  14. "
  15. DEPEND="${RDEPEND}
  16. >=dev-util/gtk-doc-am-1.12
  17. "
  18. multilib_src_install_all() {
  19. DOCS="AUTHORS ChangeLog NEWS README RELEASE"
  20. einstalldocs
  21. find "${ED}" -name '*.la' -delete || die
  22. }