logo

overlay

My own overlay for experimentations, use with caution, no support is provided

gst-plugins-ugly-1.18.0.ebuild (713B)


      1 # Copyright 1999-2019 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=6
      5 GST_ORG_MODULE="gst-plugins-ugly"
      6 
      7 inherit gstreamer-meson
      8 
      9 DESCRIPTION="Basepack of plugins for gstreamer"
     10 HOMEPAGE="https://gstreamer.freedesktop.org/"
     11 
     12 LICENSE="LGPL-2+" # some split plugins are LGPL but combining with a GPL library
     13 
     14 RDEPEND="
     15 	>=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
     16 	>=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
     17 	>=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
     18 "
     19 DEPEND="${RDEPEND}
     20 	>=dev-util/gtk-doc-am-1.12
     21 "
     22 
     23 multilib_src_install_all() {
     24 	DOCS="AUTHORS ChangeLog NEWS README RELEASE"
     25 	einstalldocs
     26 	find "${ED}" -name '*.la' -delete || die
     27 }