logo

overlay

My own overlay for experimentations, use with caution, no support is provided

gst-plugins-ugly-1.18.0-r1.ebuild (959B)


      1 # Copyright 1999-2019 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=6
      5 GST_ORG_MODULE="gst-plugins-ugly"
      6 
      7 # List done from editing meson_options.txt in app-editors/vis
      8 # - Get only the ones with no-external deps (nicely in their own block)
      9 # - :x/option\('([^']*)'.*/ c/\1/
     10 # - Press J
     11 GST_PLUGINS_BUILD="asfdemux dvdlpcmdec dvdsub realmedia xingmux"
     12 
     13 inherit gstreamer-meson
     14 
     15 DESCRIPTION="Basepack of plugins for gstreamer"
     16 HOMEPAGE="https://gstreamer.freedesktop.org/"
     17 
     18 LICENSE="LGPL-2+" # some split plugins are LGPL but combining with a GPL library
     19 
     20 RDEPEND="
     21 	>=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
     22 	>=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
     23 	>=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
     24 "
     25 DEPEND="${RDEPEND}
     26 	>=dev-util/gtk-doc-am-1.12
     27 "
     28 
     29 multilib_src_install_all() {
     30 	DOCS="AUTHORS ChangeLog NEWS README RELEASE"
     31 	einstalldocs
     32 	find "${ED}" -name '*.la' -delete || die
     33 }