logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gst-plugins-ugly-1.16.2.ebuild (951B)


  1. # Copyright 1999-2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GST_ORG_MODULE="gst-plugins-ugly"
  5. inherit gstreamer
  6. DESCRIPTION="Basepack of plugins for gstreamer"
  7. HOMEPAGE="https://gstreamer.freedesktop.org/"
  8. LICENSE="LGPL-2+" # some split plugins are LGPL but combining with a GPL library
  9. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
  10. RDEPEND="
  11. >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
  12. >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
  13. >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
  14. "
  15. DEPEND="${RDEPEND}
  16. >=dev-util/gtk-doc-am-1.12
  17. "
  18. multilib_src_configure() {
  19. gstreamer_multilib_src_configure
  20. if multilib_is_native_abi; then
  21. ln -s "${S}"/docs/plugins/html docs/plugins/html || die
  22. fi
  23. }
  24. multilib_src_install_all() {
  25. DOCS="AUTHORS ChangeLog NEWS README RELEASE"
  26. einstalldocs
  27. find "${ED}" -name '*.la' -delete || die
  28. }