logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gst-plugins-good-1.18.4.ebuild (1270B)


  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. GST_ORG_MODULE="gst-plugins-good"
  5. GST_PLUGINS_ENABLED="alpha apetag audiofx audioparsers auparse autodetect avi cutter debugutils deinterlace dtmf effectv equalizer flv flx goom goom2k1 icydemux id3demux imagefreeze interleave isomp4 law level matroska monoscope multifile multipart replaygain rtp rtpmanager rtsp shapewipe smpte spectrum udp videobox videocrop videofilter videomixer wavenc wavparse y4m"
  6. inherit flag-o-matic gstreamer-meson
  7. DESCRIPTION="Basepack of plugins for GStreamer"
  8. HOMEPAGE="https://gstreamer.freedesktop.org/"
  9. LICENSE="LGPL-2.1+"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
  11. IUSE="+orc"
  12. RDEPEND="
  13. >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
  14. >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
  15. >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
  16. orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
  17. "
  18. DEPEND="${RDEPEND}
  19. >=dev-util/gtk-doc-am-1.12
  20. "
  21. DOCS="AUTHORS ChangeLog NEWS README RELEASE"
  22. multilib_src_configure() {
  23. local emesonargs=( -Dbz2=enabled )
  24. gstreamer_multilib_src_configure
  25. }
  26. multilib_src_install_all() {
  27. einstalldocs
  28. find "${ED}" -name '*.la' -delete || die
  29. }