logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gst-plugins-good-1.18.1.ebuild (1378B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GST_ORG_MODULE="gst-plugins-good"
  5. GST_PLUGINS_ENABLED="alpha apetag audiofx audioparsers auparse autodetect avi cutter debugutils deinterlace dtmf effectv equalizer flv flx goom goom2k1 icydemux id3demux imagefreeze interleave isomp4 law level matroska monoscope multifile multipart replaygain rtp rtpmanager rtsp shapewipe smpte spectrum udp videobox videocrop videofilter videomixer wavenc wavparse y4m"
  6. inherit flag-o-matic gstreamer-meson
  7. DESCRIPTION="Basepack of plugins for GStreamer"
  8. HOMEPAGE="https://gstreamer.freedesktop.org/"
  9. LICENSE="LGPL-2.1+"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
  11. IUSE="+orc"
  12. RDEPEND="
  13. >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
  14. >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
  15. >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
  16. >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
  17. >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
  18. orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
  19. "
  20. DEPEND="${RDEPEND}
  21. >=dev-util/gtk-doc-am-1.12
  22. "
  23. multilib_src_configure() {
  24. local emesonargs=( -Dbz2=enabled )
  25. gstreamer_multilib_src_configure
  26. }
  27. multilib_src_install_all() {
  28. DOCS="AUTHORS ChangeLog NEWS README RELEASE"
  29. einstalldocs
  30. find "${ED}" -name '*.la' -delete || die
  31. }