logo

overlay

My own overlay for experimentations, use with caution, no support is provided

gst-plugins-good-1.18.0.ebuild (1002B)


      1 # Copyright 1999-2020 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=6
      5 GST_ORG_MODULE="gst-plugins-good"
      6 
      7 inherit flag-o-matic gstreamer-meson
      8 
      9 DESCRIPTION="Basepack of plugins for GStreamer"
     10 HOMEPAGE="https://gstreamer.freedesktop.org/"
     11 
     12 LICENSE="LGPL-2.1+"
     13 KEYWORDS="alpha amd64 ~arm arm64 ~hppa ia64 ~mips ppc ppc64 ~sh ~sparc x86"
     14 IUSE="+orc"
     15 
     16 RDEPEND="
     17 	>=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
     18 	>=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
     19 	>=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
     20 	>=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
     21 	>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
     22 	orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
     23 "
     24 DEPEND="${RDEPEND}
     25 	>=dev-util/gtk-doc-am-1.12
     26 "
     27 
     28 multilib_src_configure() {
     29 	local emesonargs=(
     30 		-Dbz2=enabled
     31 	)
     32 
     33 	gstreamer_multilib_src_configure
     34 }
     35 
     36 multilib_src_install_all() {
     37 	DOCS="AUTHORS ChangeLog NEWS README RELEASE"
     38 	einstalldocs
     39 	find "${ED}" -name '*.la' -delete || die
     40 }