logo

overlay

My own overlay for experimentations, use with caution, no support is provided

gst-plugins-good-1.18.0-r1.ebuild (1553B)


      1 # Copyright 1999-2020 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=6
      5 GST_ORG_MODULE="gst-plugins-good"
      6 
      7 # List done from editing meson_options.txt in app-editors/vis
      8 # - Get only the ones with no-external deps (nicely in their own block)
      9 # - :x/option\('([^']*)'.*/ c/\1/
     10 # - Press J
     11 GST_PLUGINS_BUILD="alpha apetag audiofx audioparsers auparse autodetect avi cutter debugutils deinterlace dtmf effectv equalizer flv flx goom goom2k1 icydemux id3demux imagefreeze interleave isomp4 law level matroska monoscope multifile multipart replaygain rtp rtpmanager rtsp shapewipe smpte spectrum udp videobox videocrop videofilter videomixer wavenc wavparse y4m"
     12 
     13 inherit flag-o-matic gstreamer-meson
     14 
     15 DESCRIPTION="Basepack of plugins for GStreamer"
     16 HOMEPAGE="https://gstreamer.freedesktop.org/"
     17 
     18 LICENSE="LGPL-2.1+"
     19 KEYWORDS="alpha amd64 ~arm arm64 ~hppa ia64 ~mips ppc ppc64 ~sh ~sparc x86"
     20 IUSE="+orc"
     21 
     22 RDEPEND="
     23 	>=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
     24 	>=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
     25 	>=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
     26 	>=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
     27 	>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
     28 	orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
     29 "
     30 DEPEND="${RDEPEND}
     31 	>=dev-util/gtk-doc-am-1.12
     32 "
     33 
     34 multilib_src_configure() {
     35 	local emesonargs=(
     36 		-Dbz2=enabled
     37 	)
     38 
     39 	gstreamer_multilib_src_configure
     40 }
     41 
     42 multilib_src_install_all() {
     43 	DOCS="AUTHORS ChangeLog NEWS README RELEASE"
     44 	einstalldocs
     45 	find "${ED}" -name '*.la' -delete || die
     46 }