logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gst-plugins-good-1.16.2.ebuild (1417B)


  1. # Copyright 1999-2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GST_ORG_MODULE="gst-plugins-good"
  5. inherit flag-o-matic gstreamer
  6. DESCRIPTION="Basepack of plugins for GStreamer"
  7. HOMEPAGE="https://gstreamer.freedesktop.org/"
  8. LICENSE="LGPL-2.1+"
  9. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
  10. IUSE="+orc"
  11. RDEPEND="
  12. >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
  13. >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
  14. >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
  15. >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
  16. >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
  17. orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
  18. "
  19. DEPEND="${RDEPEND}
  20. >=dev-util/gtk-doc-am-1.12
  21. "
  22. multilib_src_configure() {
  23. # Always enable optional bz2 support for matroska
  24. # Always enable optional zlib support for qtdemux and matroska
  25. # Many media files require these to work, as some container headers are often
  26. # compressed, bug #291154
  27. gstreamer_multilib_src_configure \
  28. --enable-bz2 \
  29. --enable-zlib \
  30. --disable-examples \
  31. --with-default-audiosink=autoaudiosink \
  32. --with-default-visualizer=goom
  33. if multilib_is_native_abi; then
  34. ln -s "${S}"/docs/plugins/html docs/plugins/html || die
  35. fi
  36. }
  37. multilib_src_install_all() {
  38. DOCS="AUTHORS ChangeLog NEWS README RELEASE"
  39. einstalldocs
  40. find "${ED}" -name '*.la' -delete || die
  41. }