logo

overlay

My own overlay for experimentations, use with caution, no support is provided

gst-plugins-bad-1.18.0.ebuild (2927B)


      1 # Copyright 1999-2019 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=6
      5 GST_ORG_MODULE="gst-plugins-bad"
      6 
      7 # List done from editing meson_options.txt in app-editors/vis
      8 # - Get only the ones with no-external deps (nicely in their own block)
      9 # - :x/option\('([^']*)'.*/ c/\1/
     10 # - Press J
     11 GST_PLUGINS_BUILD="accurip adpcmdec adpcmenc aiff asfmux audiobuffersplit audiofxbad audiolatency audiomixmatrix audiovisualizers autoconvert bayer camerabin2 coloreffects deb ugutils dvbsubenc dvbsuboverlay dvdspu faceoverlay festival fieldanalysis freeverb frei0r gaudieffects gdp geometrictransform id3tag inter interlace ivfpars e ivtc jp2kdecimator jpegformat librfb midi mpegdemux mpegpsmux mpegtsdemux mpegtsmux mxf netsim onvif pcapparse pnm proxy rawparse removesilence rist rtmp2 rtp sdp segmentclip siren smooth speed subenc switchbin timecode videofilters videoframe_audiolevel videoparsers videosignal vmnc y4m"
     12 
     13 inherit flag-o-matic gstreamer-meson virtualx
     14 
     15 DESCRIPTION="Less plugins for GStreamer"
     16 HOMEPAGE="https://gstreamer.freedesktop.org/"
     17 
     18 LICENSE="LGPL-2"
     19 
     20 # TODO: egl and gtk IUSE only for transition
     21 IUSE="X bzip2 +egl gles2 gtk +introspection +opengl +orc vnc wayland" # Keep default IUSE mirrored with gst-plugins-base where relevant
     22 
     23 # X11 is automagic for now, upstream #709530 - only used by librfb USE=vnc plugin
     24 # We mirror opengl/gles2 from -base to ensure no automagic openglmixers plugin (with "opengl?" it'd still get built with USE=-opengl here)
     25 RDEPEND="
     26 	>=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
     27 	>=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
     28 	>=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl?,introspection?,gles2=,opengl=]
     29 	introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
     30 
     31 	bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
     32 	vnc? ( X? ( x11-libs/libX11[${MULTILIB_USEDEP}] ) )
     33 	wayland? (
     34 		>=dev-libs/wayland-1.4.0[${MULTILIB_USEDEP}]
     35 		>=x11-libs/libdrm-2.4.55[${MULTILIB_USEDEP}]
     36 		>=dev-libs/wayland-protocols-1.4
     37 	)
     38 
     39 	gtk? ( >=media-plugins/gst-plugins-gtk-${PV}:${SLOT}[${MULTILIB_USEDEP}] )
     40 	orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
     41 "
     42 
     43 DEPEND="${RDEPEND}
     44 	dev-util/glib-utils
     45 	>=dev-util/gtk-doc-am-1.12
     46 "
     47 
     48 RESTRICT="test"
     49 
     50 src_prepare() {
     51 	default
     52 	addpredict /dev # Prevent sandbox violations bug #570624
     53 }
     54 
     55 multilib_src_configure() {
     56 	local emesonargs=(
     57 		-Dshm=enabled
     58 		-Dipcpipeline=enabled
     59 		$(meson_feature orc)
     60 		$(meson_feature vnc librfb)
     61 		$(meson_feature wayland)
     62 	)
     63 
     64 	if use opengl || use gles2; then
     65 		myconf+=( -Dgl=enabled )
     66 	else
     67 		myconf+=( -Dgl=disabled )
     68 	fi
     69 
     70 	gstreamer_multilib_src_configure
     71 }
     72 
     73 multilib_src_test() {
     74 	unset DISPLAY
     75 	# Tests are slower than upstream expects
     76 	CK_DEFAULT_TIMEOUT=300 virtx eninja check
     77 }
     78 
     79 multilib_src_install_all() {
     80 	DOCS="AUTHORS ChangeLog NEWS README RELEASE"
     81 	einstalldocs
     82 	find "${ED}" -name '*.la' -delete || die
     83 }