logo

overlay

My own overlay for experimentations, use with caution, no support is provided

gst-plugins-bad-1.18.0-r2.ebuild (2726B)


  1. # Copyright 1999-2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GST_ORG_MODULE="gst-plugins-bad"
  5. GST_PLUGINS_ENABLED="accurip adpcmdec adpcmenc aiff asfmux audiobuffersplit audiofxbad audiolatency audiomixmatrix audiovisualizers autoconvert bayer camerabin2 coloreffects deb ugutils dvbsubenc dvbsuboverlay dvdspu faceoverlay festival fieldanalysis freeverb frei0r gaudieffects gdp geometrictransform id3tag inter interlace ivfpars e ivtc jp2kdecimator jpegformat librfb midi mpegdemux mpegpsmux mpegtsdemux mpegtsmux mxf netsim onvif pcapparse pnm proxy rawparse removesilence rist rtmp2 rtp sdp segmentclip siren smooth speed subenc switchbin timecode videofilters videoframe_audiolevel videoparsers videosignal vmnc y4m"
  6. inherit flag-o-matic gstreamer-meson virtualx
  7. DESCRIPTION="Less plugins for GStreamer"
  8. HOMEPAGE="https://gstreamer.freedesktop.org/"
  9. LICENSE="LGPL-2"
  10. # TODO: egl and gtk IUSE only for transition
  11. IUSE="X bzip2 +egl gles2 gtk +introspection +opengl +orc vnc wayland" # Keep default IUSE mirrored with gst-plugins-base where relevant
  12. # X11 is automagic for now, upstream #709530 - only used by librfb USE=vnc plugin
  13. # We mirror opengl/gles2 from -base to ensure no automagic openglmixers plugin (with "opengl?" it'd still get built with USE=-opengl here)
  14. RDEPEND="
  15. >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
  16. >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
  17. >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl?,introspection?,gles2=,opengl=]
  18. introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
  19. bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
  20. vnc? ( X? ( x11-libs/libX11[${MULTILIB_USEDEP}] ) )
  21. wayland? (
  22. >=dev-libs/wayland-1.4.0[${MULTILIB_USEDEP}]
  23. >=x11-libs/libdrm-2.4.55[${MULTILIB_USEDEP}]
  24. >=dev-libs/wayland-protocols-1.4
  25. )
  26. gtk? ( >=media-plugins/gst-plugins-gtk-${PV}:${SLOT}[${MULTILIB_USEDEP}] )
  27. orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
  28. "
  29. DEPEND="${RDEPEND}
  30. dev-util/glib-utils
  31. >=dev-util/gtk-doc-am-1.12
  32. "
  33. RESTRICT="test"
  34. src_prepare() {
  35. default
  36. addpredict /dev # Prevent sandbox violations bug #570624
  37. }
  38. multilib_src_configure() {
  39. local emesonargs=(
  40. -Dshm=enabled
  41. -Dipcpipeline=enabled
  42. $(meson_feature vnc librfb)
  43. $(meson_feature wayland)
  44. )
  45. if use opengl || use gles2; then
  46. myconf+=( -Dgl=enabled )
  47. else
  48. myconf+=( -Dgl=disabled )
  49. fi
  50. gstreamer_multilib_src_configure
  51. }
  52. multilib_src_test() {
  53. unset DISPLAY
  54. # Tests are slower than upstream expects
  55. CK_DEFAULT_TIMEOUT=300 virtx eninja check
  56. }
  57. multilib_src_install_all() {
  58. DOCS="AUTHORS ChangeLog NEWS README RELEASE"
  59. einstalldocs
  60. find "${ED}" -name '*.la' -delete || die
  61. }