logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gst-plugins-bad-1.16.2.ebuild (2711B)


  1. # Copyright 1999-2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GST_ORG_MODULE="gst-plugins-bad"
  5. inherit flag-o-matic gstreamer virtualx
  6. DESCRIPTION="Less plugins for GStreamer"
  7. HOMEPAGE="https://gstreamer.freedesktop.org/"
  8. LICENSE="LGPL-2"
  9. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
  10. # TODO: egl and gtk IUSE only for transition
  11. IUSE="X bzip2 +egl gles2 gtk +introspection +opengl +orc vcd vnc wayland" # Keep default IUSE mirrored with gst-plugins-base where relevant
  12. # X11 is automagic for now, upstream #709530 - only used by librfb USE=vnc plugin
  13. # We mirror opengl/gles2 from -base to ensure no automagic openglmixers plugin (with "opengl?" it'd still get built with USE=-opengl here)
  14. RDEPEND="
  15. >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
  16. >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
  17. >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl?,introspection?,gles2=,opengl=]
  18. introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
  19. bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
  20. vnc? ( X? ( x11-libs/libX11[${MULTILIB_USEDEP}] ) )
  21. wayland? (
  22. >=dev-libs/wayland-1.4.0[${MULTILIB_USEDEP}]
  23. >=x11-libs/libdrm-2.4.55[${MULTILIB_USEDEP}]
  24. >=dev-libs/wayland-protocols-1.4
  25. )
  26. gtk? ( >=media-plugins/gst-plugins-gtk-${PV}:${SLOT}[${MULTILIB_USEDEP}] )
  27. orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
  28. "
  29. DEPEND="${RDEPEND}
  30. dev-util/glib-utils
  31. >=dev-util/gtk-doc-am-1.12
  32. "
  33. RESTRICT="test"
  34. PATCHES=(
  35. "${FILESDIR}"/${PN}-1.14.5-make43.patch # remove when bumping and switching to Meson
  36. )
  37. src_prepare() {
  38. default
  39. addpredict /dev # Prevent sandbox violations bug #570624
  40. }
  41. multilib_src_configure() {
  42. local myconf=()
  43. if use opengl || use gles2; then
  44. myconf+=( --enable-gl )
  45. else
  46. myconf+=( --disable-gl )
  47. fi
  48. # Always enable shm (shm_open) and ipcpipeline (sys/socket.h); no extra deps
  49. gstreamer_multilib_src_configure \
  50. $(multilib_native_use_enable introspection) \
  51. $(use_enable bzip2 bz2) \
  52. $(use_enable orc) \
  53. $(use_enable vcd) \
  54. $(use_enable vnc librfb) \
  55. $(use_enable wayland) \
  56. --disable-examples \
  57. --disable-debug \
  58. --without-player-tests \
  59. --enable-shm \
  60. --enable-ipcpipeline \
  61. "${myconf[@]}"
  62. if multilib_is_native_abi; then
  63. local x
  64. for x in libs plugins; do
  65. ln -s "${S}"/docs/${x}/html docs/${x}/html || die
  66. done
  67. fi
  68. }
  69. multilib_src_test() {
  70. unset DISPLAY
  71. # Tests are slower than upstream expects
  72. virtx emake check CK_DEFAULT_TIMEOUT=300
  73. }
  74. multilib_src_install_all() {
  75. DOCS="AUTHORS ChangeLog NEWS README RELEASE"
  76. einstalldocs
  77. find "${ED}" -name '*.la' -delete || die
  78. }