logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

glfw-2.7.9.ebuild (1216B)


  1. # Copyright 1999-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit toolchain-funcs multilib-minimal
  5. DESCRIPTION="The Portable OpenGL FrameWork"
  6. HOMEPAGE="https://www.glfw.org/"
  7. SRC_URI="https://github.com/glfw/glfw-legacy/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. S="${WORKDIR}/glfw-legacy-${PV}"
  9. LICENSE="ZLIB"
  10. SLOT="2"
  11. KEYWORDS="~x86 ~amd64 ~arm ~arm64 ~hppa ~ppc64"
  12. IUSE=""
  13. RDEPEND="
  14. x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
  15. virtual/opengl[${MULTILIB_USEDEP}]
  16. x11-libs/libX11[${MULTILIB_USEDEP}]
  17. x11-libs/libXcursor[${MULTILIB_USEDEP}]
  18. x11-libs/libXinerama[${MULTILIB_USEDEP}]
  19. x11-libs/libXrandr[${MULTILIB_USEDEP}]
  20. x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
  21. "
  22. DEPEND="
  23. ${RDEPEND}
  24. x11-libs/libXi[${MULTILIB_USEDEP}]
  25. "
  26. src_prepare() {
  27. sed -i 's;$(PREFIX)/;$(DESTDIR)$(PREFIX)/;' lib/x11/Makefile.x11.in || die
  28. default
  29. multilib_copy_sources
  30. }
  31. multilib_src_configure() {
  32. sed -i 's;$(PREFIX)/lib;$(PREFIX)/'"$(get_libdir);" lib/x11/Makefile.x11.in || die
  33. sh "${S}/compile.sh" || die
  34. }
  35. multilib_src_compile() {
  36. export PREFIX="/usr"
  37. emake x11 AR="$(tc-getAR)"
  38. }
  39. multilib_src_install() {
  40. emake -j1 DESTDIR="${ED}" x11-install x11-dist-install
  41. }